bootstrap报错Uncaught TypeError: Bootstrap’s dropdowns require Popper.js

bootstrap报错Uncaught TypeError: Bootstrap’s dropdowns require Popper.js的解决办法。网上各种折腾办法很多,实际上都是不正确的,并不需要引入其他外部js的。

直接解决办法就是:

<script src="./js/jquery-3.4.1.min.js"></script>
<script src="./js/bootstrap.bundle.min.js"></script>//这个文件这个文件,一定要引入
<script src="./js/bootstrap.min.js"></script>

注意一定要按照引入顺序,先jquery的js文件,因为bootstrap很多东西是基于jquery的,然后就是bundle这个js,最后才是bootstrap这个js文件。

按照以上顺序就不会再报Uncaught TypeError: Bootstrap’s dropdowns require Popper.js这个错误了

打赏

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据